Porto Functionality plugin

Home Page Forums Porto | Multi-Purpose & WooCommerce Theme Porto Functionality plugin

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3995
    myhigrow
    Participant
        Expired

        When I enable the plugin I get the following error:
        PHP Fatal error: Uncaught Error: Call to undefined method Porto_Woo::load_packages() in /srv/htdocs/wp-content/plugins/porto-functionality/porto-woo.php:27

        This field is Private Content.

        #3996
        myhigrow
        Participant
            Expired

            I have updated the plug-ins and themes to the latest versions, but the problem still exists.

            #3997
            Aizaz Awan
            Keymaster

                Hello, @myhigrow,

                Kindly consider switching the theme to the Parent Theme temporarily, as the current activation on your site is set to the Child Theme.

                Additionally, deactivate all third-party plugins on your site and reattempt the task. If this resolves the issue, kindly reactivate each third-party plugin one at a time to identify which one is causing the problem on your site.

                Please note: Before proceeding, it’s advisable to take a complete backup of your site or clone it to a test environment. This precaution ensures that any changes made can be tested without affecting the live site.

                Best Regards,
                PThemes Team.

                #4204
                bpfc87
                Participant
                    Expired

                    Hello, I have the same problem, but i dont have access to admin panel. I recived this msg, but this recovery link dont work. What can I do?

                    WordPress версия 6.4.2
                    Текуща тема: Porto (версия 7.0.1)
                    Текущо разширение: Porto Theme – Functionality (версия 2.11.1)
                    PHP версия 7.4.33

                    Данни за грешката
                    ================================
                    Грешка от вид E_ERROR беше причинена от ред 27 от файла /home/bp***/public_html/wp-content/plugins/porto-functionality/porto-woo.php. Грешка: Uncaught Error: Call to undefined method Porto_Woo::load_packages() in /home/bp***/public_html/wp-content/plugins/porto-functionality/porto-woo.php:27
                    Stack trace:
                    #0 /home/bp***/public_html/wp-content/plugins/porto-functionality/porto-woo.php(30): Porto_Woo->__construct()
                    #1 /home/bp***/public_html/wp-content/plugins/porto-functionality/porto-functionality.php(287): require_once(‘/home/bp***/…’)
                    #2 /home/bp***/public_html/wp-includes/class-wp-hook.php(324): Porto_Functionality->load_woo(”)
                    #3 /home/bp***/public_html/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(NULL, Array)
                    #4 /home/bp***/public_html/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
                    #5 /home/bp***/public_html/wp-settings.php(506): do_action(‘plugins_loaded’)
                    #6 /home/bp***/public_html/wp-config.php(96): require_once(‘/home/bp***/…’)
                    #7 /home/bp***/public_html/wp-load.php(50): require_once(‘/home/bp***2/…’)
                    #8 /home/bp***/public_html/wp-admin/admin.php(34): require_once(‘/home/bp***

                    #4206
                    dfrey
                    Participant

                        Must have been from a recent auto update. porto_woo.php code shows no such “load_packages()” method. I had to rem out ‘self::load_packages();’ to get my site back up.

                        use Automattic\WooCommerce\Packages;

                        defined(‘ABSPATH’) || exit;
                        /**
                        * Remove woo gutenberg blocks.
                        *
                        * @since 2.7.0
                        */
                        class Porto_Woo extends Packages
                        {
                        /**
                        * The Constructor
                        *
                        * @since 2.7.0
                        */
                        public function __construct()
                        {

                        remove_action(‘plugins_loaded’, array(‘Packages’, ‘on_init’));
                        if (!is_admin() && get_option(‘porto_disable_woo_blocks’, false)) {
                        unset(self::$packages[‘woocommerce-blocks’]); // woocommerce block
                        if (function_exists(‘yit_maybe_plugin_fw_loader’)) {
                        function yith_plugin_fw_is_gutenberg_enabled()
                        {
                        return false;
                        }
                        }
                        }
                        //self::load_packages();
                        }
                        }
                        new Porto_Woo();

                        #4211
                        Aizaz Awan
                        Keymaster

                            Hello, @everyone,

                            Sorry for the inconvenience but we have fixed this compatibility issue.

                            Please check our theme changelog: https://themeforest.net/item/porto-responsive-wordpress-ecommerce-theme/9207399#item-description__change_logs

                            Please update the theme and core plugin again manually by redownloading from Themeforest and it will solve your issue.

                            Please try to update the theme and porto functionality plugin via FTP or Cpanel. https://www.portotheme.com/wordpress/porto/documentation/update-theme/

                            After that, please should apply the patches in Porto > Patcher: https://www.portotheme.com/wordpress/porto/documentation/porto-patcher/

                            Best Regards,
                            PThemes Team.

                            #4212
                            dfrey
                            Participant

                                Thanks for the fast reply. I just grabbed the plugin from ThemeForest and now I can see the bug fix and it works. Still showing the same version for the plugin, though (3.0.2), but we’re up and running. Thanks.

                                #4237
                                Aizaz Awan
                                Keymaster

                                    Hello, @dfrey,

                                    Great to hear that the bug fix is working for you! I appreciate your prompt response in resolving the issue.

                                    Regarding the version display, it’s not uncommon for the version number to remain the same after a bug fix. So yes the version of the plugin is the same.

                                    If you have any further questions or encounter any issues, feel free to reach out. Thanks again for your patience!

                                    Best Regards,
                                    PThemes Team.

                                  Viewing 8 posts - 1 through 8 (of 8 total)
                                  • You must be logged in to reply to this topic.
                                  Customize Icon
                                  Need Customization? We specialize in delivering high-quality web and mobile design/development services to our clientele. Should you require customization services, please do not hesitate to reach out to us at your convenience.