Template Builder archive type doesn’t work properly with Yoast SEO plugin

Home Page Forums Porto | Multi-Purpose & WooCommerce Theme Template Builder archive type doesn’t work properly with Yoast SEO plugin

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7158
    luki
    Participant

        Hi

        I’m trying to use Porto with Template Builder and I’ve found a bug with archive type:

        – In archive type Yoast Plugin doesn’t display %title%
        – Setting permalink in archive type doesn’t work. When I do save and refresh page this field is again empty.

        How to reproduce?

        – Install empty wordpress
        – Install porto theme
        – Choose demo: Dentist
        – Install plugin: Yoast SEO
        – Go to Yoast SEO -> Settings -> Services: /wp-admin/admin.php?page=wpseo_page_settings#/post-type/service
        – Go to section: Services archive
        – Change SEO Title from: Archive %%pt_plural%% %%page%% %%sep%% %%sitename%% to %%title%% %%page%% %%sep%% %%sitename%%
        – Go to: Porto -> TemplateBuilder -> Edit Custom Services
        – Set Yoast SEO:
        —- Slug: custom-services
        —- Meta description: Sample custom services description
        – Save
        – Reload edit custom services page

        Result:
        – Slug is again empty
        – When you go to page: http://localhost:8080/service/ (remember to change displaying post type to: http://localhost:8080/sample-post/) and check source page I will find out that:
        —- html title tag is without post tile
        —- html title tag didn’t appear, our “Sample custom services description” doesn’t work..

        I wonder, because everything works fine for any service -> TemplateBuilder type single. IMO it should also work correctly for the archive.

        • This topic was modified 3 weeks, 4 days ago by luki.
        • This topic was modified 3 weeks, 4 days ago by luki.
        Attachments:
        You must be logged in to view attached files.
        #7171
        Aizaz Awan
        Keymaster

            Hello, @luki,

            I apologize for any inconvenience. I followed your steps on our test site but was unable to reproduce the bug. I might have missed a step. Could you please record a short video demonstrating the issue so I can better understand? Also, could you share the following details in the private content area of this topic after backing up your site? This will allow me to check and provide a proper solution.

            wp-admin URL:
            wp-admin username:
            wp-admin password:

            Looking forward to your response.

            Best Regards,
            PThemes Team.

            #7181
            luki
            Participant

                I’m sending link to sample in private part..

                This field is Private Content.

                #7184
                Aizaz Awan
                Keymaster

                    Hello, @luki,

                    Thanks for sharing the video. Let me explain to you.

                    You are customizing the services archive layout from template builder however, You have to customize the services page check this: https://postimg.cc/nM95jF9h Once you edit the services page with Gutenberg editor and make changes in YOAST plugin settings on the page like I did: https://postimg.cc/QBMYXhrs Here you can see the results: https://postimg.cc/jLQMPLxt

                    Just make sure that you are editing the service page with the Gutenberg editor. Do not edit the service custom layout from the template builder and do not use the classic editor plugin while editing the services page to make changes in YOAST settings.

                    Best Regards,
                    PThemes Team.

                    #7210
                    luki
                    Participant

                        Can you do the same with the Dentist demo? I have tried and I added page with slug: service – the same as PostType Services. The effect is that the page isn’t displayed, at the address /service/ I still see the archive page for services. Something tells me that I can’t have page and PostType with the same slug… :) This is ugly, because let’s say I want to have this structure of pages:

                        /service/ <- Archive with general description
                        /service/serv1 <- single service / product page
                        /service/serv2

                        Then /service/ has to be “Archive type” and I’m not able set seo tags as I’ve shown you. Each /service/serv.. works correctly with YOAST SEO.

                        #7243
                        Aizaz Awan
                        Keymaster

                            Hello, @luki,

                            Could you please provide the following details in the private content area of this topic after ensuring you have a complete backup of your site? This will allow me to review and offer an appropriate solution.

                            wp-admin URL:
                            wp-admin username:
                            wp-admin password:

                            I look forward to your response.

                            Best Regards,
                            PThemes Team.

                          Viewing 6 posts - 1 through 6 (of 6 total)
                          • You must be logged in to reply to this topic.
                          Customize Icon
                          Need Customization? We specialize in delivering high-quality web and mobile design/development services to our clientele. Should you require customization services, please do not hesitate to reach out to us at your convenience.