Reply To: Megamenu isn’t working

Home Page Forums Porto | Multi-Purpose & WooCommerce Theme Megamenu isn’t working Reply To: Megamenu isn’t working



      Thanks for contacting us.

      Alright, Let me explain to you how it works and the possible ways to fix it.

      1- Why, is this happening on mobile? The thing is mega menu has columns and columns based on the 2nd sub-menu items see the image: then the rest of the sub-menu items you want to show in these columns you will add like this: so on the desktop the menu will be open on hover but as you know mobile devices don’t have the hover functionality which is why on mobile the column sub-menu item appears and then it will show the rest of the menu items its default functionality. I hope you understand.

      2- First, Actually the thing is the requirement you want is not possible with the theme options. But it can be possible if you create 2 menus and assign the location of both menu the same see image: then both menu shows at the same time on desktop and mobile. Then you need to hide 1 menu from the desktop and 1 from mobile. for this you need to pick the class/ID of the menu how can you do that see the image: this way you be able to pick the class/ID of the menu.

      Simply copy the class/ID and then add the CSS code for “Display:none”

      This is the only possible way if you are not able to add your custom code in the Appearance >> Theme Options >> Skins >> Custom CSS by using the class/ID then you can find the way from google or any other website you want.

      I hope you understand.

      3- Secondly, Once you create different menus and assign the location of the menus different from the Appearance >> Menus you can simply choose the menus from the theme options >> menus >> mobile menu >> the menu you want to show on mobile see the image:

      4- Further, if you want anything else, then you can proceed to create a feature request on our forum here: so that our development team will notice it and remember it while working on the theme update. I hope you understand.

      That’s all.
      Have a nice day.